Welcome to Club Hot Rod!  The premier site for everything to do with Hot Rod, Customs, Low Riders, Rat Rods, and more. 

  •  » Members from all over the US and the world!
  •  » Help from all over the world for your questions
  •  » Build logs for you and all members
  •  » Blogs
  •  » Image Gallery
  •  » Many thousands of members and hundreds of thousands of posts! 

YES! I want to register an account for free right now!  p.s.: For registered members this ad will NOT show

 
Like Tree51Likes

Thread: 72elk
          
   
   

Reply To Thread
Page 8 of 8 FirstFirst 1 2 3 4 5 6 7 8
Results 106 to 110 of 110
  1. #106
    States's Avatar
    States is offline CHR Member Visit my Photo Gallery
    Join Date
    Aug 2016
    Location
    Spirit Lake
    Posts
    96
    Blog Entries
    2

    Need help. Got engine completely unattached from the car, chained hoist to engine and tried to lift it but it lifted the entire front end of the car.

  2. #107
    glennsexton's Avatar
    glennsexton is offline CHR Member/Contributor Visit my Photo Gallery
    Join Date
    Mar 2005
    Location
    Tigard
    Car Year, Make, Model: 63 Nova SS
    Posts
    2,182

    Are you pulling the engine and the transmission as a unit?

    Gotta be something still attached. The two side mounts for the engine, the exhaust, the center mount for the transmission, the transmission linkage? Don't pull too hard until you locate the problem there's things that can bu stuck and release a lot of energy when the break free causing damage or injury.

    Remember too that when pulling an engine you need to pull forward and up.

    Pictures may help..

    Good luck here.

    Glenn
    NTFDAY likes this.
    "Where the people fear the government you have tyranny. Where the government fears the people you have liberty." John Basil Barnhil

  3. #108
    States's Avatar
    States is offline CHR Member Visit my Photo Gallery
    Join Date
    Aug 2016
    Location
    Spirit Lake
    Posts
    96
    Blog Entries
    2

    Engine mount center bolts, check: two bolts on tranny support, check: speedo cable, check: exhaust, out including manifold, replacing with headers: speedo cable, check: trans linkage, check: drive shaft out, check: trans/carb linkage, check.
    I'm not clear what you mean by pull and lift, can't be pulled until top motor mount clears bracket on bottom engine mount. I lift and the holes in the motor mounts don't even come out of alignment.

  4. #109
    rspears's Avatar
    rspears is offline CHR Member/Contributor Visit my Photo Gallery
    Join Date
    Sep 2007
    Location
    Gardner, KS
    Car Year, Make, Model: '33 HiBoy Coupe
    Posts
    9,499

    Are you using an engine lift leveler, something like this - https://www.northerntool.com/shop/to...BoCKOYQAvD_BwE
    Sounds like you're trying to pull up with a bind on the mounts. Maybe put just a bit of uplift, then get below with a bar to lever the engine out of the mounts?
    Roger
    Enjoy the little things in life, and you may look back one day and realize that they were really the BIG things.

  5. #110
    States's Avatar
    States is offline CHR Member Visit my Photo Gallery
    Join Date
    Aug 2016
    Location
    Spirit Lake
    Posts
    96
    Blog Entries
    2

    Using something very similar I got at Harbor Freight. I'll try some prying.

Reply To Thread
Page 8 of 8 FirstFirst 1 2 3 4 5 6 7 8

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
Links monetized by VigLink